New member just saying Hello...

View previous topic View next topic Go down

New member just saying Hello...

Post by Cjkjr48 on Sun Mar 20, 2016 7:47 am

Just wanted to say hey, I just purchased a 1963 Skylark that needs some work to get on the road. Carb needs rebuild, floors are a little "Holy" , and the interior is rough but it runs and drives. I'm hoping to drive as I work on it this summer. It doesn't have to be pretty to be cool is my motto!!!
avatar
Cjkjr48

Posts : 2
Join date : 2016-03-19

View user profile

Back to top Go down

The author of this message was banned from the forum - See the message

Re: New member just saying Hello...

Post by StageCat on Sun Mar 20, 2016 4:19 pm

Welcome aboard, lots of helpful folks in the group.....

Tom
avatar
StageCat

Posts : 206
Join date : 2015-01-16
Location : So Cal

View user profile

Back to top Go down

Re: New member just saying Hello...

Post by Bill on Mon Mar 21, 2016 1:53 pm

Great to meet ya! Ask away if you have questions! This is a really friendly group here! Is that your car in your profile picture? Looks good!
avatar
Bill
Admin

Posts : 284
Join date : 2014-12-22
Age : 37
Location : Northern Illinois

View user profile http://skylark616263.forumotion.com

Back to top Go down

Re: New member just saying Hello...

Post by Cjkjr48 on Mon Mar 21, 2016 6:11 pm

Yes thats my car. I had trouble posting pic in the text section but I'll keep trying. Anyone have any great luck rebuilding the Rochester carb? I bought the kit but now that I have been reading it doesn't appear to be the greatest carb from the court of popular opinion...
avatar
Cjkjr48

Posts : 2
Join date : 2016-03-19

View user profile

Back to top Go down

Re: New member just saying Hello...

Post by Bill on Mon Mar 21, 2016 8:54 pm

I like it!! I am thinking of going 2 tone with my paint here this summer. Here is a thread about carb rebuilds -

http://skylark616263.forumotion.com/t84-carb-rebuild-kits

I did do it myself, and it was pretty easy. The last part of that thread is a little optimistic though - I am still having some issues, but I am betting that is with the ethanol in today's fuel. There is a user on here (Woody) who has taken the fuel injection off of a land rover and bolted it right on. If you read some history on the engine you will find out GM only used it until '63, then sold the rights to Land Rover who used the same block into the '90s. So there are a lot of aftermarket parts available. Here is the thread that Woody talks about his fuel injection swap -

http://skylark616263.forumotion.com/t19-fuel-injection-swap
avatar
Bill
Admin

Posts : 284
Join date : 2014-12-22
Age : 37
Location : Northern Illinois

View user profile http://skylark616263.forumotion.com

Back to top Go down

Re: New member just saying Hello...

Post by Bill on Mon Mar 21, 2016 9:00 pm

Oh, and as far as posting the pictures, it is a terrible process. You have to host the picture first (when you post or reply there are a bunch of icons - to host an image you click on the icon that looks like a picture with a floppy disk next to it, 3rd one to the left of the you tube icon). Once you upload the picture it will give you a link. You then have to copy the link into the dialog box that comes up when you click on the icon that looks like a chain with a plus symbol next to it.

It is a bad process, but the forum is free to set up and has limitations as a result. I have toyed with changing over to a better site, but haven't gotten to it yet. If you don't want to go through that whole process, you can just email me the pics and I will post them for you. My email is W_A_schafer@yahoo.com.

avatar
Bill
Admin

Posts : 284
Join date : 2014-12-22
Age : 37
Location : Northern Illinois

View user profile http://skylark616263.forumotion.com

Back to top Go down

Re: New member just saying Hello...

Post by StageCat on Tue Mar 22, 2016 7:23 am

A fairly easy way for me to post pictures here and other sites is to download photos to your photo bucket acct.(if you don't have one, open one its free) Click on image to use, to right side of photo under "Share this photo" click on IMG, it will flash copied. Go to your thread on any given forum and right click, then paste and your done.
avatar
StageCat

Posts : 206
Join date : 2015-01-16
Location : So Cal

View user profile

Back to top Go down

Re: New member just saying Hello...

Post by Bill on Tue Mar 22, 2016 4:26 pm

Good suggestion. I need to start using photobucket again.
avatar
Bill
Admin

Posts : 284
Join date : 2014-12-22
Age : 37
Location : Northern Illinois

View user profile http://skylark616263.forumotion.com

Back to top Go down

Re: New member just saying Hello...

Post by regal81455 on Wed Mar 23, 2016 12:42 pm

Actually posting a bunch of images is easy -- click the icon with the diskette as mentioned above, then hit select files, once you're done adding all the files you want to add, hit send all, then once they've completely loaded hit the insert all button and it does everything for you -- no need to copy and paste the links that are provided.

Additionally, Im waiting patiently to see how Keith's car likes the EFI -- Ive been doing a bunch of reading on some of the MGB forums and alot of them are complaining that the EFI simply does not like to work with the older "buick" branded 215 engines for some reason and since they are a sealed unit there isn't alot of tweaking that can be done.  That's just what Ive read -- could be all user error IDK, hence why I'm waiting to see how Keiths install goes before considering any of this for myself.

And yes, WELCOME TO THE BOARD -- if you're in need of anything just ask!

_________________
1961 SKYLARK 2 DR COUPE
215 CI 185 HP 2 SPD
avatar
regal81455
Admin

Posts : 441
Join date : 2014-12-29
Age : 38
Location : BFE, IL

View user profile

Back to top Go down

Re: New member just saying Hello...

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum